侵权投诉
订阅
纠错
加入自媒体

美权威机构:微软苹果Linux等操作系统遭受严重安全漏洞威胁

2018-05-10 08:31
科技最前线
关注

5月10日消息,美国计算机安全应急响应中心(以下简称“CERT”)今日通过公告宣称,Windows、macOS、Linux、FreeBSD、VMware和Xen等基于x86 AMD和英特尔CPU的系统都在遭受一个严重安全漏洞的影响,而该漏洞是由于操作系统开发者曲解了英特尔和AMD两家芯片厂商的调试文档所致。

CERT方面表示,受影响的操作系统和管理程序制造商周二发布了针对普通漏洞的补丁,这些普通漏洞可能让有效的黑客攻击者“读取了计算机内存中的敏感数据,或者是控制了一些低级别的操作系统功能。

目前,包括苹果、DragonFly BSD、FreeBSD、微软、红帽、SUSE Linux、Ubuntu、VMware和Xen等公司已发发布了可用的补丁。以Linux系统为例,有两大独立的问题影响了Linux内核功能以及该内核功能的KVM管理程序。目前,所有可以更新的补丁链接均可以在CERT公告中获取。

根据红帽公司的描述,该漏洞来源于操作系统和管理程序处理现代CPU中特定调试功能的方式,在这些案例中,处理特定调试异常情况的方式正是引发这些漏洞的重要根源。红帽公司在公告中表示,“总体而言,在指令边界出现了异常,此前的所有边界都能够顺利完成,而此次异常漏洞出现之后,在处理过程中就立即被黑客加以利用。”

对于Linux操作系统而言,这一漏洞可能会导致系统崩溃,而且还能够让黑客提升“访客”账户的访问权限。

微软表示,该漏洞允许黑客在内核模式下运行任意代码。微软表示,“为了嗅探这一漏洞,黑客首先需要登录系统。接下来,黑客可以运行特定应用来控制那些受影响的系统。”

VMware方面声称,该公司的管理程序没有受到影响,但是,包括VMware vCenter服务器、VMware数据保护和VMware vSphere Integrated Containers在内的产品可能受到了影响。

与此同时,Xen方面也表示,所有版本的Xen程序都受到了影响,但这一漏洞只能被软件虚拟化(PV)“访客”账户嗅探和利用,而硬件虚拟化(HVM)将无法发现和利用这一漏洞。

CERT表示,这一问题是由于操作系统开发者不正当处理这些异常情况所致。虽然这些漏洞与CPU的设计无关,但是,对异常的曲解主要是由于对这些指导说明缺乏清晰的理解。

这一漏洞最初由Everdox Tech的尼克-彼得森(Nick Peterson)和Triplefault.io的纳曼贾-穆尔斯马吉克(Nemanja Mulasmajic)发现。这两人将在BlackHat 2018上展示他们的研究成果。他们在研究报告中表示,“这是一个非常严重的安全漏洞,但却由于对相关文件产生不完整和不清晰的理解而导致系统开发者忽略了这一漏洞。”(来源:腾讯科技 编译:金全)

声明: 本文由入驻维科号的作者撰写,观点仅代表作者本人,不代表OFweek立场。如有侵权或其他问题,请联系举报。

发表评论

0条评论,0人参与

请输入评论内容...

请输入评论/评论长度6~500个字

您提交的评论过于频繁,请输入验证码继续

暂无评论

暂无评论

文章纠错
x
*文字标题:
*纠错内容:
联系邮箱:
*验 证 码:

粤公网安备 44030502002758号